[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Hi all, 

Does anyone have any experience using DLMs under
IRIX 6.5?  I have a DLM that works fine under Linux,
but fails under IRIX.  I then tried the IDL example
called "testmodule" that comes with the distribution, 
and it fails with the same error under IRIX - the 
DLM cannot be loaded:

% cd test
% cp /usr/local/rsi/idl/external/dlm/* .
% vi Makefile    <change IRIX to IRIX64>
% make
% idl

IDL> DLM_LOAD, 'testmodule'
% DLM_LOAD: Error loading sharable executable.
  Symbol: IDL_Load, File = /usr/people3/mallors/test/testmodule.so
  1291373:/usr/local/rsi/idl_5.2/bin/bin.sgi/idl: rld: Fatal Error:
  Cannot Successfully map soname
  '/usr/people3/mallors/test/testmodule.so' under any of the
  filenames /usr/people3/mallors/test/testmodule.so 
% Execution halted at:  $MAIN$       
IDL> exit
% file /usr/people3/mallors/test/testmodule.so
    ELF N32 MSB mips-4 dynamic lib MIPS - version 1

I did have to change the testmodule Makefile a little
since it looks for the system called "IRIX", and uname
on my system is "IRIX64".   I tried setting the
IDL_DLM_PATH environment variable as well (and even
LD_LIBRARY_PATH), but no luck.


Robert S. Mallozzi                                       256-544-0887
                                                      Mail Code SD 50
http://gammaray.msfc.nasa.gov/           Marshall Space Flight Center 
http://cspar.uah.edu/~mallozzir/                 Huntsville, AL 35812