[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IDL falls to sleep!

In article <3729AD4C.55BFDAC1@astro.uio.no>,
	Terje Fredvik <tfredvik@astro.uio.no> writes:
> One of my programs is generating large data arrays which is saved
> to file using the ordinary "save, [filename], [variable]" command. 
> The program has worked excellent, but yesterday something strange
> started to happen; after saving a few arrays IDL went into sleep
> mode (according to the UNIX "top" command) after writing 4 bytes 
> to file. Nothing happened (I waited several minutes), and IDL 
> did not respond to ctrl-c, but had to be brutally killed. I
> started IDL once more, but the same problem showed up once again;
> IDL fell to sleep when saving (not the same file as last time!).
> I repeated this several times, but every time with the same result.
> Is this a problem caused by my code, by IDL or my UNIX alpha station?

One of my co-workers is also having this problem, although it's not 
when writing files.  He was doing many fits in a loop using SVDFIT.
At a random point in the loop, IDL halts (no CPU activity), CNTRL-C
does nothing, and IDL must be killed "brutally".
I traced the line at which it halted - it was at a call to 
NR__SVDFIT (two underscores), which is an IDL internal routine, 
so could not do anything else.  We switched back to IDL 5.1 
(instead of 5.2), and the problem seemed to go away.  I never 
contacted RSI, because I couldn't write a simple program to reproduce 
the error.  This is under Solaris OS.

Robert S. Mallozzi                                       256-544-0887
                                                      Mail Code ES 84
Work: http://www.batse.msfc.nasa.gov/    Marshall Space Flight Center 
Play: http://cspar.uah.edu/~mallozzir/           Huntsville, AL 35812