[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: IDL falls to sleep!

In article <7gcvla$393$1@hammer.msfc.nasa.gov>,
  mallors@ips1.msfc.nasa.gov (Robert S. Mallozzi) wrote:
> In article <3729AD4C.55BFDAC1@astro.uio.no>,
> 	Terje Fredvik <tfredvik@astro.uio.no> writes:
> >
> > One of my programs is generating large data arrays which is saved
> > to file using the ordinary "save, [filename], [variable]" command.
> > The program has worked excellent, but yesterday something strange
> > started to happen; after saving a few arrays IDL went into sleep
> > mode [...]
> One of my co-workers is also having this problem, although it's not
> when writing files.  He was doing many fits in a loop using SVDFIT.
> At a random point in the loop, IDL halts (no CPU activity), CNTRL-C
> does nothing, and IDL must be killed "brutally".
> I traced the line at which it halted - it was at a call to
> NR__SVDFIT (two underscores) [...]

Praise the lord!  RSI has tried to convince me that I am the only one in the
world having this problem with 5.2, and that it has something to do with my

I have experienced this problem on three Solaris machines under IDL 5.2.  I
cannot reproduce the problem using 5.0.3 on the two machines that have it
installed.  The systems are an Ultra 5, Ultra 10, and Sparc 10.  I was unable
to reproduce the problem in NT.

I have a long-ish (2000-line) code that consistently causes this problem,
after 1-10 hours of computation.  I've sent it to RSI, who says they're
unable to reproduce it.  I don't know why this would be, but at this point
they tell me there's nothing to be done.  If someone else has a
self-contained program that demonstrates this situation -- or general
observations about it -- _please_ send it to RSI.  E-mail me and I'd be happy
to pass along my code and my exchanges with RSI support.

For background, my program executes about 10^5 iterations through a set
of matrix transformations.  It's not writing any files, and I don't believe
I use the NR__SVFIT routine that Robert mentions above.  Memory usage is
~ 50 MB, and I get the same behavior from IDL and IDLDE.  In the former,
ctrl-c will sometimes give the 'Interrupt encountered' message, not always.


| Henry Throop   throop@colorado.edu   (303) 492-1628  |
| Laboratory for Atmospheric and Space Physics         |
| University of Colorado, Boulder      80309-0392      |

-----------== Posted via Deja News, The Discussion Network ==----------
http://www.dejanews.com/       Search, Read, Discuss, or Start Your Own