[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RedHat-6.0 with Glibc2.1 breaks IDL-5.2

lrnittler@my-dejanews.com wrote:

> OK, I also am having trouble getting IDL to work with redhat 6.0. I tried the
> above approach after copying libc-2.0.7.so from /usr/i386-glibc20-linux/lib/
> (where the compat files are put) to /lib, but even with the 2.0.7 library I
> get the same error message. Any ideas?

We managed to get IDL to work by installing the compatability libraries. I
then modified the idl script (the one which runs the binary) at the end to


if [ -e /lib/ld-2.0.7.so ] ; then
 exec $app $* $APP_ARGS

 export LD_LIBRARY_PATH="${libdir}:${LD_LIBRARY_PATH}"
 exec ${libdir}/ld-2.0.7.so $app $* $APP_ARGS

This seems to work, although we haven't tried running programs with external
shared libraries.

Jeremy Sanders

Jeremy Sanders  jss@ast.cam.ac.uk     Pembroke College, Cambridge. CB2 1RF
(01223) 337511  Institute of Astronomy, Madingley Road, Cambridge. CB3 0HA