[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: underscore bug?

In article <907kdl$kn2$1@nnrp1.deja.com>, noymer@my-deja.com says...
> I know this sounds weird, but I am wondering is there
> a known bug---or feature---regarding the underscore
> character (_) in IDL 5.3 (linux)?
> I was making some SURFACES and all of a sudden the fonts
> were all $%^&ed up and I could not fix it for about an hour
> of messing around.  I backtracked to an old version that
> worked and found that it lacked the underscore character in
> things like dataset and output filenames.  I was desperate, so
> I tried renaming all the things I had with the underscore
> and the problem went away.
> It was such a time sink, I don't even feel like pinpointing it.
> BUT... is this a known "issue"?
> - Andrew
> Sent via Deja.com http://www.deja.com/
> Before you buy.
 Hi, Andrew,
I don't know if this is a related problem but I also had some very weird 
behavior for a widget program when I used underscore as the name in the 
title bar of the widget. (ie: 	XMANAGER, "my_widget_prog",.....). 
Replacing the "_" by a "-" fixed the problem.
However, it seems that I also abuse of neurotoxic substances since the 
CW_animate in the /lib uses:  XMANAGER, "CW_ANIMATE Demo",... and works 
perfectly fine. (???)
Please let me know if you can get a reasonable explanation for this.

Thomas Launey
Laboratory for Memory and Learning, Brain Science Institute, RIKEN
Saitama, JAPAN
email: t_launey@brain.riken.go.jp